Can I use my mac for OET@Home?

Yes, you must be running MacOS 10.13 or higher. For full system requirements, please see the ProProctor™ User Guide.

Note: 2014 and newer computers should all exceed the recommended screen resolution.

Have more questions? Submit a request

Comments

Take the next step towards your international healthcare career. Book OET
Powered by Zendesk